Editing adducts in functional analysis creates unknown error


Since it is possible to edit Adducts now in the functional analysis I wanted to change it to:
M+H [1+], M+Na [1+], 2M+H [1+], M-NH3+H [1+], M-H [1-], M+HCOO [1-]

However when I run it I get an “unknown error”. What could cause this unknown error?

In R it runs with these adducts, however I wanted to try it on the webserver to be able to use the network explorer afterwards.

Hi Sarmeie,
Please follow this post (Requirements for Troubleshooting) for further troubleshooting.

I am facing the same problem.

To Reproduce:

Try to do functional analysis (using the web interface) with any data. After normalization of data, the interface asks for the parameters to be defined: " Specify analysis parameters"

If we use the default parameter for adducts (or currency), it works. But changing (including/excluding) even a single parameter gives the above mentioned “Unknown Error” and the program doesn’t run

Exactly, thank you for the good explanation!

Thank you for the details. The issue should be fixed. Please try again.

Thank you. I just tried it again and it worked.

It was working fine, but again throwing an error today. Could you check again, please?

Erorr >>>

Error There is something wrong with the MS Peaks to Paths analysis:

Possible causes of error (last one being the most relevant):
Unknown Error Occured

We had some unrelated problem with the newest version of MetaboAnalyst, so we reverted back to an older version to keep things stable for a workshop we are running. It will be changed back very soon.