Can not perfomr t.test in MetaboAnalyst


This page indicates an unknown error that is unique to your data and parameters. We suggest the following steps

Self Help

  • Have you read the FAQs, Data Format and Tutorials?
    These resources provides detailed explanations for common questions received from users. Please first go through these resources first.
  • Have you tried our example data to see if the issue still exists?
    Most of the time, the issue is related to improper data format. Although we try to give informative error messages, there are always exceptions. Here are three tips:
    1. Open your file in a text editor (not a spreadsheet program) to see the details - are these values comma separated (.csv) or tab separated (.txt)?
    2. You may need to search “How to save my file as a .csv format” to get more detailed instructions;
    3. Several example datasets are provided in the upload page, please choose the one that matches your data type to see if the iss

I am also having problems with some files not being able to perform t-tests with. It will perform the fold-change, but not the t-test. Experienced user so not sure what is going on? Please check

1 Like

bumping this for visibility. I think the update did some thing to the one factor analysis feature. Data that worked fine before the update now returns no results

Hello everyone,

I have the same problem. I did a few tests, it seems to depend on the number of variables whether the t-test works or not. The error occurs with more than 1000 features, but not with 999 variables (at least with my data).
Hope this helps you


1 Like

It would be very helpful if you can give a reproducible example per our post guide