Unable to install MetaboAnalyst on Window via Option A and B

Lately i’ve been trying to install MetaboAnalyst, I’ve tried Option A and B, but they both turned out failure.
At first i tried option A. After installing all depency package but “SSPA”, since it’s not available on R4.2.2. Then error occured saying “Rcpp.h” doesn’t insist, the same issue @ [tfccheng] has postedhttps://omicsforum.ca/t/failed-to-install-metaboanalystr/1154.
I then installed Rcpp and copy Rcpp.h and relative file to [C:\RBuildTools\4.2\x86_64-w64-mingw32.static.posix\include]. Then I re-run Option A code and get message below

Blockquote> devtools::install_github(“xia-lab/MetaboAnalystR”, build = TRUE, build_vignettes = FALSE)
Downloading GitHub repo xia-lab/MetaboAnalystR@HEAD
:heavy_check_mark: checking for file ‘C:\Users\10959\AppData\Local\Temp\RtmpsFDE3a\remotes5d4816302f4d\xia-lab-MetaboAnalystR-ffdb096/DESCRIPTION’ (399ms)
─ preparing ‘MetaboAnalystR’: (3.8s)
:heavy_check_mark: checking DESCRIPTION meta-information …
─ cleaning src
─ checking for LF line-endings in source and make files and shell scripts (1.5s)
─ checking for empty or unneeded directories
─ building ‘MetaboAnalystR_3.2.0.tar.gz’

  • installing source package ‘MetaboAnalystR’ …
    ** using staged installation
    ** libs
    rm -f fortran/decorana.o c/Internal_utils_batch.o c/util.o cpp/melt.o c/fastmatch.o c/nncgc.o c/mzROI.o c/xcms_binners.o Exports.o
    gfortran -fno-optimize-sibling-calls -O2 -mfpmath=sse -msse2 -mstackrealign -c fortran/decorana.f -o fortran/decorana.o
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/Internal_utils_batch.c -o c/Internal_utils_batch.o
    c/Internal_utils_batch.c: In function ‘do_decorana’:
    c/Internal_utils_batch.c:114:3: warning: this ‘for’ clause does not guard… [-Wmisleading-indentation]
    114 | for (i = 0, nid = 0; i < nr*nc; i++)
    | ^~~
    c/Internal_utils_batch.c:118:5: note: …this statement, but the latter is misleadingly indented as if it were guarded by the ‘for’
    118 | int ibegin = (int ) R_alloc(nr, sizeof(int));
    | ^~~
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/util.c -o c/util.o
    g++ -std=gnu++11 -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -fopenmp -O2 -Wall -mfpmath=sse -msse2 -mstackrealign -c cpp/melt.cpp -o cpp/melt.o
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/fastmatch.c -o c/fastmatch.o
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/nncgc.c -o c/nncgc.o
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/mzROI.c -o c/mzROI.o
    gcc -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -O2 -Wall -std=gnu99 -mfpmath=sse -msse2 -mstackrealign -c c/xcms_binners.c -o c/xcms_binners.o
    c/xcms_binners.c:11:1: warning: "/
    " within comment [-Wcomment]
    11 | /

    c/xcms_binners.c: In function ‘_breaks_on_binSize’:
    c/xcms_binners.c:361:7: warning: unused variable ‘idx’ [-Wunused-variable]
    361 | int idx = 0;
    | ^~~
    g++ -std=gnu++11 -I"C:/PROGRA~1/R/R-42~1.2/include" -DNDEBUG -I"C:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/include" -fopenmp -O2 -Wall -mfpmath=sse -msse2 -mstackrealign -c Exports.cpp -o Exports.o
    g++ -shared -s -static-libgcc -o MetaboAnalystR.dll tmp.def fortran/decorana.o c/Internal_utils_batch.o c/util.o cpp/melt.o c/fastmatch.o c/nncgc.o c/mzROI.o c/xcms_binners.o Exports.o -fopenmp -LC:/PROGRA~1/R/R-42~1.2/bin/x64 -lRlapack -LC:/PROGRA~1/R/R-42~1.2/bin/x64 -lRblas -lgfortran -lm -lquadmath -LC:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/lib/x64 -LC:/RBuildTools/4.2/x86_64-w64-mingw32.static.posix/lib -LC:/PROGRA~1/R/R-42~1.2/bin/x64 -lR
    installing to C:/Users/10959/AppData/Local/R/win-library/4.2/00LOCK-MetaboAnalystR/00new/MetaboAnalystR/libs/x64
    ** R
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
    there is no package called ‘glasso’
    Calls: … loadNamespace → withRestarts → withOneRestart → doWithOneRestart
    Execution halted
    ERROR: lazy loading failed for package ‘MetaboAnalystR’
  • removing ‘C:/Users/10959/AppData/Local/R/win-library/4.2/MetaboAnalystR’

Then Option B was also tried, which turned out as below:

Blockquote Error in download.file(p, destfile, method, mode = “wb”, …) :
‘wget’ call had nonzero exit status

Has any one encountered same issues above? It’s their any solution to these problem? Much appreciated for any advise!