/Problems with loading numerical/continuous metadata in MicrobiomeAnalyst

Dear all,

In my metadata, I have 3 different categorical and 2 different numerical (continuous) types of data. When I attempt to load my metadata file as txt-format to perform Marker Data Profiling, MicrobiomeAnalyst only detects the categorical data, whereas the numerical data seem to disappear. No values are missing from the data and all commas/dots have been removed. I have even tried to rearrange the order of the different factors, as well as reducing the total number of factors to two (one categorical and one numerical). However, MicrobiomeAnalyst still doesn’t recognize the numerical data. Does anyone have a solution to this problem?

Thanks in advance!

Best regards

Import_MappingDATA_3.txt (3.3 KB)
Import_OTUtable.txt (208.1 KB)
Import_Taxonomy.txt (72.4 KB)

Please follow the post guide, and provide details with data that allow others to reproduce the issue. In your case, which module? where is the other data in addition to the metadata?


Thanks for bringing the lack of information to my attention. I’ve uploaded the remaining metadata. The issue specifically concerns Marker Data Profiling.

Have a nice day.


This is caused by a data format transformation function which introduce some unexpectable blanks to the numbers. We have fixed the issue. You can try again.

Hope this helps!

1 Like

This topic was automatically closed after 18 hours. New replies are no longer allowed.