Mummichog generic error online, works in R

We are running a functional analysis using Mummichog (v2) on the lipids main chemical class. This analysis was successfully run last year with ppm = 20. We are re-running the data using the data_original file from that analysis and the same parameters as before. The analysis is successful when the ppm error is at 10 or lower, but when we set the ppm to our desired level of 20, we get a generic error. Other parameters include positive mode, p-value cutoff of 0.05, and pathways with 3 entries. The analysis also fails with ppm = 20 and pathways with 5 entries minimum. I have also tried ppm = 12 and 15 without luck. I have also tried data as .csv and as .txt, without luck at the higher ppm.

Notably, analysis with the same data and parameters (ppm = 20) in MetaboAnalystR (version 3.3.0) does not result in an error. Is this a bug in the online 5.0 version?

data_original.csv (262.5 KB)

This is not unexpected - mummichog was designed with high-resolution LC-MS (10 ppm or less) in mind. When you give a ppm=20, there will be too many possible candidates, leading to large computing cost during permutations, especially using large libraries such as lipid chemical classes. The system will terminate a computing process if it takes a very long time (because the server is shared by many users). You can probably get some results using pathway analysis (which is small) with ppm=20, however, the accuracy will be very low. See below for results from our latest study - Figure 4.