It seems the metadata cannot be imported anymore; the system returns a message:

ErrorThe content of meta-data file is not formatted correctly! Please check!

Even when using the example provided (, the same message pops-up, so I guess it is some error with the server.

Anyone else experiencing this? Could you please have a look?



Emmanuel, are you using the Statistical Analysis with metadata table module? I had this issue too a couple of days ago. The first version of metadata I was using was working perfectly. Then this message came up (likely R commands being very picky). As a workaround, I rearranged the order of my metadata columns to have a categorical one (column B) next to the sample names (column A) and it uploaded fine. I originally had some numerical data in the column B. My samples are arranged in rows. Hope this helps you out!

Hi Emmanuel, thanks for reaching out. I think you are using LC-MS spectral processing module based on your description. Could you please provide more information or an example to reproduce the potential issue? We can do more checking and debugging based on your case.

Hello, I noticed that you were using Statistical Analysis with metadata table. Can you provide more information or an example for us to reproduce the potential issue? We are happy to help to make your analysis more smooth!


1 Like

Faeces_S183_Metadata2 - for OmicsForum.csv (180 Bytes)

Hi Zhiqiang,

The csv is for the metadata table that works without error in the Stat Analysis module. Note Column B is a categorical data variable. I’ve removed most of my information for privacy reasons of my participants, but you can use the csv file to create some dummy data.

In the previous version I had, the age column (a numerical variable) was in column B. This version worked initially, but for whatever reasons, stopped working a couple of days ago when I tried to use it with the module.

Cheers, Amber :slight_smile:

Hi Qiang,

Thanks for your reply. Yes, I am trying to use the LC-MS spectra processing module.

Here are printscreens of the content of the metadata file (.txt) I am using. It is simply the .txt provided as an example on the load page that was downloaded and modified. This is the way I always work, and usually it works fine…

Thanks for your help!



Hi Emmanuel,

Thanks for your feedback. I noticed that group A and B has only two samples. This is not allowed. At leaset 3 samples are required for each group. In addition, it is hard to reproduce the error message based on your screenshots. Could you please share both raw data and metadata file with me privately? I am quite happy to do more in-depeth testing and debugging for your case.


Hello Amber,
Thanks for your sharing. I fully got your question. Please make sure the column B is the main/primary metadata factor, and contains three replicates for each group. Otherwise, it may not allow you to pass.

Dear Dr. Qiang,

I am also experiencing problems in uploading my metadata file when using the module “Statistical Analysis [metadata table]” (I used this metadata file in MetaboAnalyst some time ago without any trouble). This is the error message:

ErrorFailed meta-data integrity check.
Possible causes of error (last one being the most relevant):
Unknown Error Occurred

Look forward of hearing from you.

Dear Qiang,
Thank you for the offer! I just sent you a mail with a link to download the dataset.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.