Metaboanalyst-Functional Analysis does not return any results only a blank page


I am trying to perform a functional analysis in the MetaboAnalyst suite and it results in a blank page (attached images). It yields neither scatter plot nor a matrix. I attach the dataset I used and the preprocessing steps I followed.

Ion Mode: Negative

Mass Tolerance: 16.9 ppm

Retention Time: seconds

Data Format: samples in columns
Filtering: enable Filtering features if their RSDs are >20 & Interquartile range

Data editor: include only High and Low group
Normalization: Normalization by median, Log transformation, Pareto scaling

Set parameter: Default parameters

I also performed the analysis with another dataset that I had performed functional analysis in the past where MetaboAnalyst yielded results. Yet, using this dataset now I got the blank page in the View result.

So I would like to ask why I get the blank page?
Is there any problem with the MetaboAnalyst Functional analysis module or there is a problem in the attached dataset ?
Why I get the blank page even in a dataset that I had succesfully analyzed using Metaboanalyst in the past?

metaboanalyst_input.csv (129.3 KB)

Thank you in advance,

That was a internal bug. I have fixed it. MetaboAnalyst will be updated in 72h.

Hello, I am still getting the same result, as the image in the initial post.

One potential issue is that your data does not contain enough signals for enrichment analysis. Have you tried statistical analysis to see if there are many significant features (enrichment analysis requires 100s of features to give meaningful results)?

You can upload the complete ranked peak list based on t-statistics (not peak table) - the algorithm can use the top 10% for enrichment analysis - this is the classical mode

I’ve had this happen too when I had m.z and retention time separated by just one underscore “_” and needed two “__” like this example ID : 81.5222__642.31

Thank you for your answer, this seems to be the problem.
After the filtering step (enable Filtering features if their RSDs are >20 & Interquartile range) I get approximately 200 peaks from which less than 100 are significant according to the statistical analysis. Moreover, in the functional analysis module in ‘set parameter’ tab, only if I set the p-value cutoff to 1, I get the plot and the table in the view results tab. But of course with no statistically significant results.
Thank you for your help, I will mark the answer as solution.

Thank you for your comment, I have checked the data and fortunately they have double underscore.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.