Installing package dependencies and packages

until now I’ve played around with the online version of MetaboAnalyst and it works well. But since I’d like to dive a bit deeper into the data, an installation of the R program would be of great use. Unfortunately, I’m new to this language and thus even the installation seems to be problematic. I’ve installed Rtools and Rbase (4.2.0). Option 1 is using the metanr_packages. This I assume I run in RStudio and once the function is run and metanr_packages() is run as well the following message pops up:

'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:

Bioconductor version 3.15 (BiocManager 1.30.18), R 4.2.0 (2022-04-22 ucrt)
Installing package(s) 'SSPA'
Warning: unable to access index for repository
  cannot open URL ''
Installation paths not writeable, unable to update packages
  path: C:/Program Files/R/R-4.2.0/library
    MASS, nlme
[1] "SSPA"               " packages added..."
Warning message:
package ‘SSPA’ is not available for Bioconductor version '3.15'

A version of this package for your version of R might be available elsewhere,
see the ideas at  here

I have simply no idea what to exactly do at this point, so I tried Option 2, which is using the pacman package, which leads to the following message:

Installing package into ‘C:/Users/dymph/AppData/Local/R/win-library/4.2’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/zip' length 389104 bytes (379 KB)
downloaded 379 KB

package ‘pacman’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
> library(pacman)
> pacman::p_load(c("impute", "pcaMethods", "globaltest", "GlobalAncova", "Rgraphviz", "preprocessCore", "genefilter", "SSPA", "sva", "limma", "KEGGgraph", "siggenes","BiocParallel", "MSnbase", "multtest","RBGL","edgeR","fgsea","httr","qs"))
Installing package into ‘C:/Users/dymph/AppData/Local/R/win-library/4.2’
(as ‘lib’ is unspecified)
Warning: unable to access index for repository
  cannot open URL ''

This all seems pretty frustrating and any advice on how to get this to run would be greatly appreciated.
Thanks so much, :slightly_smiling_face:

Hi Ilja,

Thanks for report this issue. SSPA is not available in the latest Bioconductor. We have also updated the dependency of MetaboAnalystR on SSPA. Please try it again now.

Zhiqiang Pang

Although this post was from two years ago, I’m experiencing the same issue with SSPA. Do I just remove it from the line of code or is there another package to replace it ?

1 Like