Generic Error Functional Analysis

Hi all,
peak_table_2.csv (15.1 KB)

I am trying to run the functional Analysis of metabolomics data generated from mouse livers, starting from the peak intensity table.
The table that I upload is a .csv file which contains the name of the features (MZ__RT) in the rows and the samples on the columns, as you can see from the file I uploaded here.

I normally skip the filtering (because I have less than 5000 features), and I remove the Quality controls and the blanks by editing the groups, before performing the data transformation (Log transformation). Finally I set the algorithm (I tried both Mummichog and GSEA), the parameters (p-value 0.1) and the pathway library (I tried both of the mouse libraries).
However when I try to proceed I get back the Generic error page for which I put a screenshot in the attached files.

I guess this error is due to an error in the data formatting, or because I only have 54 features in the table, and the algorithm cannot find any enriched pathway.

Can you please help me to solve this problem?
Thank you in advance.

This data is inherently incompatible with the algorithms which expect global / untargeted metabolomics generated from high-resolution LC-MS. You may have less than 5,000 features. However, less than 1,000 features will be quite unusual for untargeted metabolomics from mammalian samples.