Error when running function mSet<-Read.TextData(mSet, "metaboanalyst_input.csv", "colu", "disc")

Dear Developers,
I run the command line mSet<-Read.TextData(mSet, “metaboanalyst_input.csv”,
“colu”, “disc”)
using the example data,
then i got the following error, any idea on this issue? thanks.
Error in Read.TextData(mSet, “metaboanalyst_input.csv”, “colu”, “disc”) :
object ‘anal.type’ not found

More information, I found when I run the command line “mSet<-InitDataObjects(“pktable”,“stat”, paired=FALSE)”,
I got mSet is NULL, so cause the above error. why mSet is NULL? thanks.

seems like when Initial data objects every time, we need to restart R, and remove all the mSet object, otherwise InitDataObjects() will return NULL.
I am not sure if it affects the results or miss something.

Hi Chenx,
Thanks for posting this question. Everytime you finish a complete analysis of a specific module, you need to clean the environment and do the analysis for another one. This is highly recommended and required when your code running into an error and cause the mSet into NULL.