Error in Marker Data Profiling

I am trying to use the Microbiome Analyst marker data profiling tool to do some data analysis and I keep running into an error that we cant figure out. I have consulted the FAQ’s, and tried different file types/formats and alterations to my data and metadata. The program appears like it is acknowledging that all of my inputs are appropriate but it gives an error message that is lacking the possible cause, seen in the attached screenshot. I am not sure how to attach our data sheets but I can provide those as well to help with trouble shooting.

1 Like

Hello, would you please send your files to for trouble shooting?


Thanks for this forum! I have been experiencing the exact same problem with a 16S dataset - has there been any solution? I tried an ITS dataset now and it seems to be working fine but not sure what the problem with 16S is since the error does not say.
Looking forward to some help.


Hello Yao, I sent you the files last week on the 13th. Just checking to see if you got them or not and possible timeline on troubleshooting?

Hello Keagan, Thanks for your reminder.
I just found your data and have a quick check. The problem drop into an inner build function of the phyloseq package. So I need more time to check if we can handle it from our side. Will get back to you in next few days.


I get the same problem with my 16S data. For my colleague it’s working, but I don’t know the problem when it doesn’t show the errors. Did you find a solution yet?


same problem here!!!..
tried with different formats and it does not work.

Hello everyone,
Thanks for sharing your experiences to help improve our tool. Please always double-check the labels and format in your input tables. They are very likely to be the cause of the issues.

You can see my answer to Keagan to check if it is the same case as yours. He shared his data with me so that the issue might be kind of specific. But the special characters can always be a problem.

If you still have questions, don’t hesitate to contact me. It is better to share your data for further troubleshooting, if possible.


Hello Keagan, I finally figure out the issue. It was caused by the unexpected space in you taxonomy labels. e.g.

as you can see, there should not be space between the semicolons. Usually, they are either all together or can be directly removed.

We are able to deal with this issue from our website now. You can try again at anytime.

Hope this helps.

Hello, I have been experiencing the exact same problem with a 16S dataset - has there been any solution? Looking forward to some help.


The problem was caused by the unexpected special marks in the taxonomy annotation.
Please check my response email for the correct format attached and carefully check the input files when uploading.
Hope this helps.

Hello Yao,

Thank you very much for your help in advance,

But in other cases, i had another problem with my Analysis Overview. On my Experimental Factors that’s only show two factors, while in my metadata there are several factors. Has there been any solution?

Thank you for your attantion

Best regards,


Hello Syifa,
The two experimental factors were deleted during the processing because some factors contain only one sample. Usually, they are not fit for the statistical comparison.
Hope this make sense


I have the same problem and have gone through the responses above, but do not see any of those errors in my files. Here is a screen shot of the error. I cannot proceed past this step due to the error.

Hello,would you please provide details for trouble shooting following the post guideline? Thanks.

Hi Yao,
Thanks for responding to my post. The problem has been resolved. It turned out to be “Blank cells” in my taxonomy file. Thanks!

I am also having same exact problem (error! Possible cause of error last one being the most relevant one) i tried to resolve this but so far unsuccessful in doing so. Could you please help me out in this?

Please follow our post guideline for detail trouble shooting.

these are the data on which i tried to perform the analysis but when i tried to proceed further to data inspection step it shows an error saying : Possible causes of error (last on being the most relevant one) ; please look into the data and help me out in the same.

UrbanMDF2.txt (105 Bytes)
UrbanTaxonomyF2.txt (320.5 KB)
UrbanTableF2.txt (151.4 KB)

Hello Yao,
still waiting for your response on above uploaded data, please look into it and help me out in the same.