Problem with Data Normalization Step in Marker Data Profiling Module


I have been experiencing a problem with MicrobiomeAnalyst with the Marker Data Profiling Module. I have listed the issue and steps I took. Please read below.

* Which tool and which module: 
    * Tool: MicrobiomeAnalyst 2/0
    * Module: Marker Data Profiling - Analyze marker gene counts data
* Provide a copy of your data, or indicate which example data you used: 
    * The sample data used is provided below and categorized into 3 files (OTU/ASV table, Metadata file, Taxonomy table) 
* Document all steps leading to the issue. Sometimes screenshots may be necessary: 
    * Below are the steps that were performed leading up to the issue: 
        1. Make and upload the OTU/ASV table to match the requirement of microbiomeanalyst 
        2. Make and upload the Metadata file to match the requirements of microbiomeanalyst
        3. Make and upload the Taxonomy table to match the requirements of microbiomeanalyst
        4. Set “Taxonomy Labels” to “Not Specific/Other
        5. Pressed Submit and continued to the “Data Integrity Check” where everything looked good, so pressed Proceed
        6. Next, I went to the “Data Filtering” where I first kept the low count filter and low variance filter default and clicked submit and was able to proceed and move on to the “Data Normalization” step. 
        7. Then, in the “Data Normalization” step I kept the parameters default and did not change anything and this is where the issue arises. After I click “Submit”, I am not able to click proceed and the proceed button is greyed out. I was not able to go to the next steps and see my data and got stuck at this step. Additionally, I went back to the “Data Filtering” step and changed the parameters and did the same with the “Data Normalizing” step, but I was still not able to proceed further from the “Data Normalization” step. 
    * Also, I went back into the OTU/ASV table file and tried to make the numbers smaller by rounding and dividing it by 100, thinking that the problem might be because the data set is too large. But when I did this and followed steps 1-7 again, I still was not able to proceed further than the “Data Normalization” step. 

The issue in this case is that I am not able to go past the “Data Normalization” step even though I have properly formatted the files needed for Marker Data Profiling. I need help in troubleshooting this issue and would like a solution to fix the issue. Please take the sample data I provided and try to run it through the Marker Data Profiling module. Please let me know what the solution is or if there is any additional information needed.

OTU:ASVtable_NOTROUNDED.csv (142.5 KB)

Metadata.csv (404 Bytes)

Taxonomy.csv (83.0 KB)

Hello,I have check your files, it was not marker gene file. That’s why it cannot pass through the process.

You can try our SDP module which is dedicated to the functional profile as shown below:

I think this is more suitable for your data.
Hope this helps!