Issue with Dose-Response on ExpressAnalyst


I keep getting an error message or “no genes” message when I’m trying to generate a tPOD for my data…

After putting my data through ExpressAnalyst as followed:

  1. Upload

  2. Normalize

  3. DEG Analysis (I get DEG results)

  4. Dose-Response Analysis

As you can see in step #4, this is the error message I keep getting… I’ve attached my data in case someone wanted to run through it and see.

Any help would be greatly appreciated,

S2fid_abundance_table_all_samples_submit_2_expressanalyst_ULSFO.txt (2.0 MB)

Hi Emily :slight_smile:

Thanks for letting us know. This has to do with the transition from FastBMD to ExpressAnalyst. The curve fitting step cannot handle negative values in the data because some parts involve performing a log transform. To solve this, we add a constant value to the normalized gene expression matrix to shift all values above zero. This step was missed when we ported over the curve fitting - I’ve added it now and verified that it works with your data. The public version of ExpressAnalyst should be updated in the next day or so.



I’m still having issues with the Dose-Response aspect of Expressanalyst…

When I run some of my data (can’t attach data since the file is too big) I don’t get any BMDs, however if I upload the exact same data to FastBMD I do get fitted genes and BMDs…

Is there still issues with the migration?

I just checked the data that you attached previously, and that is working for me online. So, from this comment am I correctly interpreting that it’s working for some datasets but not for others?

We recently realized that datasets where doses are not ordered from low to high were causing errors in the BMD quality filtering step (this does not cause issues in FastBMD) and have updated the code to handle datasets where doses are included in any order. If this describes your data, the server with the fix will be updated soon. Otherwise, you can manually re-order the doses prior to uploading and it should work.

If this does not describe your data, can you email me a copy so that I can look into it?

Hi Jess,

It’s a different dataset than the initial post. I tried it again on ExpressAnalyst for dose-response but got the following message:

I’ll email you the new dataset to try.

Has this been fixed? I am getting the same error.

I am also getting the same error still for files that worked on fastbmd