Error when trying to run Heat Tree Analysis

Error when trying to run Heat Tree Analysis

Web page display:
Possible causes of error (last one being the most relevant)

This prompt is wrong in R language:
mbSet<-PrepareHeatTreePlot(mbSet, “Area”, “Phylum”, “dbgr”, “dft”, “BS_vs_R”, 0.05, “false”, “heat_tree_0”,“png”)

My original data is on this website:
I want to know the reason for the mistake,thanks.

Hello, the problem was caused by the processing of the taxa table. We have fixed the issue and will update the website soon. You can try later.

thanks a lot,I’ll try it later

I tested it and found some small problems.
When the Taxonomy level is Family, similar errors will still occur.
and ,In some cases, there is no text display on the Heat Tree

Have you checked the parameters, such as the Wilcoxon p-value cutoff? The new error might be due to no difference detected given the cutoff you set. I increase it to 1(just for explain the issue), then I can get the figure below:

Could you please give me an example of the case without text labels? (e.g. R code for generate the Heat Tree)

It’s really a parameter problem about Wilcoxon p-value cutoff. It’s OK after modification

Thank you again

case without text labels

mbSet<-PrepareHeatTreePlot(mbSet, “State”, “Family”, “dbgr”, “dft”, “S_vs_H”, 0.05, “false”, “heat_tree_3”,“png”);

Hello, did you already fix this problem? I’ve got the same error and the calculation interrupts before there is a plot.

This is my R-Code: |mbSet<-PrepareHeatTreePlot(mbSet, “SampleType”, “Genus”, “pgy”, “dft”, “Dry_vs_CONVL”, 1.0, “false”, “heat_tree_14”,“png”);|

Thanks a lot for answering!

…nor does SparCC run. Do you have an idea where could be the mistake in my data sets? Up to now (step 14), everything worked like stated in Chong et al. (2020). Thank you!


Could you update your post based on our response to this question?

That will be helpful for checking the problems.