[Error in PerformDataAnnot function of ExpressAnalystR]

Dear Colleagues,

I am trying to perform the annotation task for my expression dataset using the PerformDataAnnot of ExpressAnalystR.

I am starting with a single gene expression table mode.

The information about my data are:

My organism: R. norvegicus
Data type: Microarray (intensities)
ID type: Affymetrix Rat Genome 230 2.0 Array
Gene-level summarization: Mean

Therefore, the scripts for using ExpressAnalystR for the annotation task is:


pacman::p_load(igraph, RColorBrewer, qs, rjson, RSQLite)




dataSets ← ReadTabExpressData(“rat_data.txt”)
dataSets ← PerformDataAnnot(“rat_data.txt”, “rno”, “array”, “rat2302”, “mean”)

However, when I was trying to run the PerformDataAnnot, I encountered an error:

trying URL ‘https://www.expressanalyst.ca/ExpressAnalyst/resources/data/rno/rat2302.rds
Content type ‘unknown’ length 129506 bytes (126 KB)
downloaded 126 KB

Error: database disk image is malformed
In addition: Warning message:
Couldn’t set synchronous mode: database disk image is malformed
Use synchronous = NULL to turn off this warning.

The session info underlying the analysis are:

R version 4.2.2 (2022-10-31 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 22000)

Matrix products: default

[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252 LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] ExpressAnalystR_1.0.0 Cairo_1.6-0 ggplot2_3.4.0 RSQLite_2.2.19 rjson_0.2.21 qs_0.25.4
[7] RColorBrewer_1.1-3 igraph_1.3.5 affy_1.74.0 Biobase_2.56.0 BiocGenerics_0.42.0

loaded via a namespace (and not attached):
[1] bitops_1.0-7 matrixStats_0.63.0 bit64_4.0.5 doParallel_1.0.17 httr_1.4.4 GenomeInfoDb_1.32.4
[7] tools_4.2.2 affyio_1.66.0 utf8_1.2.2 R6_2.5.1 DBI_1.1.3 colorspace_2.0-3
[13] GetoptLong_1.0.5 withr_2.5.0 tidyselect_1.2.0 gridExtra_2.3 preprocessCore_1.58.0 bit_4.0.5
[19] compiler_4.2.2 cli_3.4.1 pacman_0.5.1 stringfish_0.15.7 scales_1.2.1 stringr_1.5.0
[25] digest_0.6.30 DOSE_3.22.1 XVector_0.36.0 htmltools_0.5.3 pkgconfig_2.0.3 fastmap_1.1.0
[31] htmlwidgets_1.5.4 GlobalOptions_0.1.2 rlang_1.0.6 rstudioapi_0.14 RApiSerialize_0.1.2 visNetwork_2.1.2
[37] shape_1.4.6 farver_2.1.1 generics_0.1.3 jsonlite_1.8.3 BiocParallel_1.30.4 GOSemSim_2.22.0
[43] dplyr_1.0.10 RCurl_1.98-1.9 magrittr_2.0.3 GO.db_3.15.0 GenomeInfoDbData_1.2.8 Matrix_1.5-3
[49] Rcpp_1.0.9 munsell_0.5.0 S4Vectors_0.34.0 fansi_1.0.3 ggnewscale_0.4.8 viridis_0.6.2
[55] lifecycle_1.0.3 stringi_1.7.8 ggraph_2.1.0 MASS_7.3-58.1 zlibbioc_1.42.0 plyr_1.8.8
[61] qvalue_2.28.0 grid_4.2.2 blob_1.2.3 parallel_4.2.2 ggrepel_0.9.2 DO.db_2.9
[67] crayon_1.5.2 lattice_0.20-45 graphlayouts_0.8.4 Biostrings_2.64.1 splines_4.2.2 circlize_0.4.15
[73] KEGGREST_1.36.3 ComplexHeatmap_2.15.1 pillar_1.8.1 fgsea_1.22.0 reshape2_1.4.4 codetools_0.2-18
[79] stats4_4.2.2 fastmatch_1.1-3 glue_1.6.2 RcppParallel_5.1.5 BiocManager_1.30.19 data.table_1.14.6
[85] png_0.1-8 vctrs_0.5.1 tweenr_2.0.2 foreach_1.5.2 gtable_0.3.1 purrr_0.3.5
[91] polyclip_1.10-4 tidyr_1.2.1 clue_0.3-63 assertthat_0.2.1 cachem_1.0.6 ggforce_0.4.1
[97] tidygraph_1.2.2 viridisLite_0.4.1 tibble_3.1.8 iterators_1.0.14 AnnotationDbi_1.58.0 memoise_2.0.1
[103] IRanges_2.30.1 cluster_2.1.4

I tried several ways to troubleshoot the error, such as re-installing ExpressAnalystR, and re-installing RSQLite, but none of them worked.

May I ask whether anybody has encountered the same issues as me? Or whether anybody knows how to solve the problems.

Please kindly let me know your idea about how to solve the problem. I very much appreciate that.

Thank you very much in advance.